Starsza wersja programu uplook<x> Agent nie może być usunięta (Błąd 1714).
Instalacja aplikacji uplook Agent nie została pomyślnie zakończona i wyświetlany jest powyższy komunikat. Czasami również mogą pojawić następujące komunikaty błędu:
- „Błąd 1612. Źródło instalacji dla tego produktu nie jest dostępne. Sprawdź, czy źródło istnieje i czy możesz uzyskać do niego dostęp.”
- „Funkcja, której próbujesz użyć, znajduje się w zasobie sieciowym, który jest niedostępny. Kliknij przycisk OK, aby spróbować ponownie, lub wprowadź alternatywną ścieżkę do folderu zawierającego pakietu instalacyjnego ‚agent.msi\update.msi” w polu poniżej.”
Przyczyna:
Błąd 1714 jest kodem błędu oprogramowania InstallShield. Sygnalizuje niepowodzenie procesu instalacji. Na etapie zgłoszenia błędu nie jest znana dokładna jego przyczyna. Problemem może być spowodowany przez brak dostępu do pakietu instalacyjnego wykorzystanego do instalacji uplook agent z użyciem polityki GPO. Każdy z pakietów instalacyjnych zgodnych z Windows Installer podczas instalacji zapisuje w rejestrze w kluczu SourceList* ścieżkę dostępu do ostatniego wywołania instalatora. Ma to na celu wykorzystanie takiego pakietu w przyszłości np. podczas wyboru funkcji Napraw lub deinstalacji aplikacji. Jest to normalne zachowanie pakietu instalacyjnego .msi i nie dotyczy tylko agenta uplook-a. „When you install an application using Windows Installer, those Windows Installer applications try to return to the path they were installed from when they need to install new components, repair the application, or update the application. This location is called the Windows Installer source location. ”
Po instalacji agenta, w rejestrze dla klucza
[HKEY_CLASSES_ROOT\Installer\Products\{ProductCode}\SourceList
tworzone są wpisy:
- LastUsedSource
- PackageName
Rozwiązanie:
Poniższe czynności umożliwiają usunięcie wpisu rejestru przechowującego informację o ostatnim położeniu pliku instalacyjnego agenta(LastUsedSource), który był wykorzystany do instalacji. Podczas wykonywania poniższych czynności należy zachować maksymalną ostrożność. Należy przeprowadź operacje dla wszystkich komputerów, dla których pojawia się powyższy komunikat błędu przy próbie instalacji uplook agent:
1. Uruchom Edytor rejestru (Regedit.exe).
2. Zlokalizuj następujący klucz:
[HKEY_CLASSES_ROOT\Installer\Products\]
3. Wyszukaj w kluczu:
[HKEY_CLASSES_ROOT\Installer\Products\]
frazę: uplook
4. Za pomocą menu Rejestr wyeksportuj wybrany klucz rejestru
[HKEY_CLASSES_ROOT\Installer\Products\{IDENTYFIKATOR_PRODUKTU}\]
który zawiera parametr ProductName= uplook<X> agent, (gdzie <X> to numer wersji agenta) w celu wykonania jego kopii zapasowej. Przechowuj plik reg w bezpiecznej lokalizacji na wypadek, gdyby zaszła konieczność zaimportowania go w przyszłości.
5. Następnie usuń cały klucz:
[HKEY_CLASSES_ROOT\Installer\Products\{IDENTYFIKATOR_PRODUKTU}\]
który zawiera parametr ProductName= uplook<X> agent, gdzie <X> to numer wersji agenta (np. uplook6 agent):
6. Zamknij Edytor Rejestru
7. Wykonaj ponownie instalację Agenta uplook.